PHP Warning: Module 'json' already loaded in Unknown on line 0


“PHP Warning: Module *** already loaded” seems to be a very common warning for freshly installed PHP. If you happen to see the example below here then this post may help you

PHP Warning:  Module 'json' already loaded in Unknown on line 0

In this case, the reason may be that the modules json is loaded twice, look into the php.ini files and find this line and comment it out with a comma

;extension=json.so

Don’t forget to look into both /etc/php5/cli and /etc/php5/apache2 if the warning appears both in your command line and web server.

There is a chance that you have installed the php5-json package in your Linux system and it also enable the extension somewhere in a config file therefore the duplication occurs. I would recommend to use the package from your distro repositories to make sure that everything is up to date.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s